Getting AD0125: Authentication Failed ERROR while start the GridDB Node

Home Forums Developer Forum Getting AD0125: Authentication Failed ERROR while start the GridDB Node

This topic contains 17 replies, has 1 voice, and was last updated by  Shinya Kaji 9 months, 1 week ago.

Viewing 15 posts - 1 through 15 (of 18 total)
  • Author
    Posts
  • #18873

    Suresh PS

    Hi,

    I have installed the GridDB Standard Edition V3.5.0. in CentOS 7.

    I have done the below steps.

    1. Successfully Installed the below RPM files.
    a, griddb-se-server-3.5.0-linux.x86_64.rpm
    b, griddb-se-client-3.5.0-linux.x86_64.rpm
    c, griddb-se-c_lib-3.5.0-linux.x86_64.rpm
    d, griddb-se-java_lib-3.5.0-linux.x86_64.rpm
    e, griddb-se-docs-3.5.0-linux.x86_64.rpm

    2. Set the password for gsadm user

    3. Set the path for environment variables (GS_HOME, GS_LOG)
    $ export GS_HOME=/var/lib/gridstore
    $ export GS_LOG=/var/lib/gridstore/log

    4. Set the password for GridDB administrator
    $ gs_passwd admin
    Password: xxxxxxxx
    Retype password: xxxxxxxx

    5. Checked the Server Version
    $ gsserver –version
    GridDB version 3.5.0 build 30549 Standard Edition

    6. Set the name for installed Cluster
    $ vi gs_cluster.json

    “clusterName”:”griddbcluster”,

    But I am getting AD0125: Authentication Failed error message when I try to start the GridDB node using $ bin/gs_startnode command.

    Bin folder and gs_startnode file has full permission (Ownership, Read, Write & Execute) for gsadm user.

    Guide me for the further process to resolve this issue.

    Thanks & Regards,
    Suresh PS

    #18923

    Shinya Kaji

    Hi Suresh,

    I’ll try to re-produce your issue on my environment. Please give me a little more time for your solution.

    Shinya

    #18973

    Suresh PS

    Hi Shinya,

    That’s fine for me.

    Request you to provide me the solution as soon as possible.

    Thanks & Regards,
    Suresh PS

    #18983

    Shinya Kaji

    Hi Suresh,

    I installed GridDB SE v3.5.0 in my fresh CentOS 7.3 environment, and tried to re-produce your issue. But I don’t have such an error when I invoke “gs_startnode” command from gsadm user console. I had a little different procedure with you, such as setting hostname properly, and not setting GS_HOME and GS_LOG environment variables since these are defined in gsadm’s .bash_profile.

    Please let me confirm. Did you invoke “gs_startnode” from gsadm user or another user account?

    Shinya

    #18993

    Suresh PS

    Hi Shinya,

    After tried with “gdadm”, I tried to invoke “gs_startnode from “root” user. but same error occurred.

    Thanks & Regards,
    Suresh PS

    #19003

    Shinya Kaji

    Hi Suresh,

    I could re-produce your issue on my environment. The root cause is USER/PASS mismatch in your environment. Once you changed administrator user (admin) password from default one (admin), you also need to tell the new password with “gs_startnode” command. Here are some solutions. Either 1 or 2 will be okay to solve your issue.

    1. Run “gs_startnode” command with GridDB’s user and password
    If you changed your admin password from default, you should specify USER and PASS when invoking “gs_startnode” command with “-u” option. For example, if you use admin user, command will be as below.

    $ gs_startnode -u admin/{YOUR_PASS}

    Please see “5.2 Common GridDB commands” in “GridDB Operation Control Guide” for more about command options.

    2. Modify GS_PASSWORD in gridstore.conf
    If you changed your admin password from default, you should change GS_PASSWORD in /etc/sysconfig/gridstore/gridstore.conf too.

    If 1 or 2 doesn’t solve your issue, please let me know.

    Shinya

    #19013

    Suresh PS

    Hi Shinya,

    Thank you so much for your support.

    I executed $ bin/gs_startnode -u admin/PASSWRD command.

    AD0125: Authentication Failed error is not occurring.

    But I am getting below error Message.

    AD0103: Failed to start the GridDB node.
    Check the event log file. (gridstore-YYYYMMDD-n.log, gsstartup.log)

    Request your support to resolve this issue.

    Thanks & Regards,
    Suresh PS

    #19033

    Suresh PS

    Hi Shinya,

    Can you able to reproduce this below issue?

    AD0103: Failed to start the GridDB node.
    Check the event log file. (gridstore-YYYYMMDD-n.log, gsstartup.log)

    Request you to provide me the solution as soon as possible.

    Thanks & Regards,
    Suresh PS

    #19083

    Shinya Kaji

    Hi Suresh,

    In my environment, I can’t see “AD0103: Failed to start the GridDB node.” error. I’ll try to find more information on your issue, but can you give us the corresponding error events in log files please?

    Shinya

    #19113

    Suresh PS

    Hi Shinya,

    I mailed you the below log files.

    1. gridstore-20171214.log
    2. gsstartup.log

    Request you to provide me the solution as soon as possible.

    Thanks & Regards
    Suresh PS

    #19123

    Shinya Kaji

    Hi Suresh,

    It looks there is mis-configuration in your cluster definition file (/var/lib/gridstore/gs_cluster.json). Please confirm you set /cluster/clusterName parameter properly.

    Shinya

    #19173

    Suresh PS

    Hi Shinya,

    Yes I have configured the cluster name in /var/lib/gridstore/gs_cluster.json file.

    Here is the gs_cluster.json file content.

    {
    “dataStore”:{
    “partitionNum”:128,
    “storeBlockSize”:”64KB”
    },
    “cluster”:{
    “clusterName”:”griddbcluster”,
    “replicationNum”:2,
    “notificationAddress”:”239.0.0.1″,
    “notificationPort”:20000,
    “notificationInterval”:”5s”,
    “heartbeatInterval”:”5s”,
    “loadbalanceCheckInterval”:”180s”
    },
    “sync”:{
    “timeoutInterval”:”30s”
    },
    “transaction”:{
    “notificationAddress”:”239.0.0.1″,
    “notificationPort”:31999,
    “notificationInterval”:”5s”,
    “replicationMode”:0,
    “replicationTimeoutInterval”:”10s”
    }
    }

    Thanks & Regards,
    Suresh PS

    #19183

    Suresh PS

    Hi Shinya,

    Can you able to reproduce this below issue?

    AD0103: Failed to start the GridDB node.

    Do you need any other information / data?

    Request you to provide me the solution as soon as possible.

    Thanks & Regards,
    Suresh PS

    #19193

    Shinya Kaji

    Hi Suresh,

    Umm, your cluster definition file seems to be configured properly. No error happened in my environment with your file. Let me dig into more details.

    Shinya

    #19223

    Shinya Kaji

    Hi Suresh,

    I am talking with GridDB team about your issue. Could you let me know the results on commands below?

    $ ls -l /var/lib/gridstore/*
    $ cat /var/lib/gridstore/conf/gs_cluster.json
    $ cat /var/lib/gridstore/gs_cluster.json

    Also let me confirm your environment variable in your gsadm user. Please run following command and let me know the result.

    $ env | grep GS_HOME

    Shinya

Viewing 15 posts - 1 through 15 (of 18 total)

You must be logged in to reply to this topic.